Welcome, Guest
Username: Password: Remember me

TOPIC: Starting concern

Starting concern 10 years 6 months ago #11894

  • Il Duce
  • Il Duce's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
I’ve got a little nagging issue.....

Yesterday morning before leaving home and yesterday afternoon when leaving work, I turned the bike on, the neutral light was showing green but yet when I hit the start button nothing happened. It eventually took but it worries me a little.

Any idea what it could be? Starter switch, ignition, starter motor or just a gremlin?
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11896

  • Boeloe
  • Boeloe's Avatar
Hi,

just a small gremlin. I would start with the clutch & sidestand cutout switches. Clean them or better still, bypass them ;) , then it will never leave you stranded again.
Just my 5c
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11901

  • SKIM
  • SKIM's Avatar
Boeloe is reg, daai twee goed kan jpu soos n regte aap laat lyk.
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11903

  • Il Duce
  • Il Duce's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
Thanks Boeloe. Remember I've been riding a '97 bullet proof GS until now and never had to worry about things like this before :laugh:
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11911

  • mcpan
  • mcpan's Avatar
hey my bike did that.... i took of the battery clamps and cleaned it (removed all acid) put it back and since now 100%
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11914

  • Dick
  • Dick's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 2423
  • Thank you received: 384
As jy sukkel om die clutch en sidestand switches te by-pass, vra vir KLR doctor, hy het myne uitgesort!
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11917

  • Il Duce
  • Il Duce's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
Thanks for the feedback guys.

OK the bike doesn't have a cut out switch for the side stand. It did do it again and I found that if I just pull the clutch in and try again it starts. So it seems it could be the clutch cut out switch.

Anyone know where that switch is located?

BTW please note my change in username to keep it aligned with my nick on Wild Dogs.
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11918

  • Boeloe
  • Boeloe's Avatar
Il Duce wrote:
Thanks for the feedback guys.
Anyone know where that switch is located?

lets see if i can upload a file with the procedure.

EDIT.......
:angry: :( Sorry... the file is too big to upload.
Last Edit: 10 years 6 months ago by Boeloe.
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11921

  • Il Duce
  • Il Duce's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
Boeloe is it possible you can mail it to me? My mail address is This email address is being protected from spambots. You need JavaScript enabled to view it.
The administrator has disabled public write access.

Re:Starting concern 10 years 6 months ago #11928

  • mcpan
  • mcpan's Avatar
follow the little electric wire to the clutch.... in that piece where the clutch handle and cable conect.... its in there...
The administrator has disabled public write access.