Topic-icon KLR behaving strangely

  • Trompie
  • Trompie's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 1 month ago #116323 by Trompie
KLR behaving strangely was created by Trompie
Good evening to Everyone
Went for a ride today towards Kayser's Beach. Long story short , was cruising at a 100 km/h and half way there the bike started jerking, similar to fuel starvation. Decided to pull in at the farm to have a look see.

1) The temperature was fine.
2) on reaching the gravel road I slowed down to bout 40 and the problem got worse.

At the farm I pulled the bike apart,

1) Checked the petcock, pulled off the fuel supply line and cranked the bike, fuel was coming out
fine .
2) Checked the spark plug and plug lead, no sign of damage or arcing
3) Bike starts fine and idle fine.
4) Bike does have a slight pop on deceleration and hard acceleration but bought it like that with a
Leo Vince pipe on .
5) No breaks in any wiring and no loose connections to the battery.

Put everything together and hoofed it back home. on the gravel it stuttered and spluttered but once on the blacktop, the bike was running smooth again at 90 - 100 km/h. During the trip home I realized that every time I hit a bump in the road the bike would behave as if starved of fuel, this theory was confirmed as I was travelling through the Buffalo Pass( a very bumpy section of road.)
Once on the N2 bike was running fine again. Any advise please, as to what could possible cause this . Only other hardware I have not checked yet for loose parts is the carburetor.

Thank you in advance

Please Log in or Create an account to join the conversation.

  • Slowmow
  • Slowmow's Avatar
  • Offline
  • Lieutenant
  • Lieutenant
  • Once you go black, you don't go back
More
3 years 1 month ago - 3 years 1 month ago #116325 by Slowmow
Replied by Slowmow on topic KLR behaving strangely

During the trip home I realized that every time I hit a bump in the road the bike would behave as if starved of fuel, this theory was confirmed as I was travelling through the Buffalo Pass( a very bumpy section of road.)
Once on the N2 bike was running fine again.


Sounds like a possible electrical problem. As the wires shake you either have a lose connection or a short.

The only way I can think of locating the problem is let the bike idle and try to move the wire harness and connectors around to simulate "bumps"

2015 NC750X
Last edit: 3 years 1 month ago by Slowmow.
The following user(s) said Thank You: Trompie

Please Log in or Create an account to join the conversation.

  • Abre
  • Abre's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Little Falls, Woesrand, Jhb
More
3 years 1 month ago #116326 by Abre
Replied by Abre on topic KLR behaving strangely
Also check the connections at the battery.

Abré le Roux
The adventure is out there.....
The following user(s) said Thank You: Trompie

Please Log in or Create an account to join the conversation.

  • Trompie
  • Trompie's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 1 month ago #116331 by Trompie
Replied by Trompie on topic KLR behaving strangely
Afternoon,

Firstly thanks for the advise on this topic.
Just some feedback.
Checked the electrical system as suggested, could not find any shorts
Tested the rectifier?? I think that is what its called, and operating fine
Drained fuel out of the carburettor
Found the the fuel outlet thingy on the petcock pulls out completely, prately'ed into place.
Checked the vacuum hose again, no cuts .

Then the test drive, Took it slow over bumps, no hickups. Then thought to check it with aggressive ear twisting, popping and spluttering back with a with a vengeance. Will now check if the choke is not an issue and pull the carburettor and check it over, if I can't find the problem it is off to find a good mechanic in East London.

Cheers vir eers

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #116443 by Kykdaar
Replied by Kykdaar on topic KLR behaving strangely
Did you check the side stand switch?

Please Log in or Create an account to join the conversation.

More
3 years 4 weeks ago - 3 years 4 weeks ago #116457 by LennyB
Replied by LennyB on topic KLR behaving strangely
Have you done any changes to the bike prior to this happening?

I once did a service on the bike, and ended up leaving the spark plug gap tooooo big, this caused a similar result as what you are experiencing.
And this after we changed the CDI and cleaned out the carb etc etc... a small thing like that, the spark plug gap :dry:

Any dirt in the carb?
Last edit: 3 years 4 weeks ago by LennyB.

Please Log in or Create an account to join the conversation.

  • Trompie
  • Trompie's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 4 weeks ago #116465 by Trompie
Replied by Trompie on topic KLR behaving strangely
Thanks for the input. Side stand switch was disabled by previous owner.
No changes to the bike. Carb cleaned again, bowl drained and everything put back as it was taken out. Problem still there. Checked spark plug gap, still within spec. It is booked in for Wednesday. Hopefully the problem will be sorted.

Please Log in or Create an account to join the conversation.

  • Keith
  • Keith's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Ek val eerder n 1000 keer as om op te hou ry
More
3 years 3 weeks ago #116482 by Keith
Replied by Keith on topic KLR behaving strangely
This is just a though to myself. Sounds like a wiring problem, although you did say you checked the wiring. Saying this for two reasons. 1) because one of the fuses played a very bad trick on us on one of our trips a while back. Basically same senario. We had almost the hole bike apart, after checking the fuses and they SEEMED in tack. Eventually it was found with the gravel road the fuse came loose inside the cap, where it was doing its evil deed, so no one would notice. For that is the reason, i believe most people change to blade fuses. 2) one of the connecters hiding away in those covers which seemingly conspires with them to keep as if they are together, but are not really kept me busy 2 weeks, also on similar conditions, although this was on my sons pit bike, and it was the wire leeding to the coil. It would start, idle nice, but as soon as you rev it up, it starts to huff and puff. So please keep us posted. Would be nice to know, if these little buggers :evil: are out of my life, and buggering someone else. :woohoo: :laugh:

Please Log in or Create an account to join the conversation.

  • Trompie
  • Trompie's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 2 weeks ago #116557 by Trompie
Replied by Trompie on topic KLR behaving strangely
Evening, some feed back on the problem. Took the Klein Land Rover to Motor Mecca as I eventually gave up. The problem was a loose ignition, lesson learned, check all the bolts. Bike is running sweet now , no hick ups.

Please Log in or Create an account to join the conversation.

More
3 years 2 weeks ago #116558 by Piet
Replied by Piet on topic KLR behaving strangely
Glad you got it sorted! And that the forum member advice was spot on. ;)

Well done guys!

Please Log in or Create an account to join the conversation.